QGIS 3: Roteiro para a Instalação do Linux Ubuntu 18.04 ‘Bionic Beaver’

A exemplo do que foi observado para as versões Linux e Windows, este é roteiro para instalação do sistema QGIS no Linux mais recente (18.04 ‘Bionic Beaver’). Use o Terminal e siga esses passos para a instalação da ferramenta no sistema Linux:

a) Se necessário, execute o Terminal e digite o comando abaixo para descobrir a versão do seu Linux Ubuntu

cat `ls /etc/*release /etc/*version`

b) Em seguida, digite este comando para ter acesso à lista de fontes do sistema:

sudo gedit /etc/apt/sources.list

c) Adicione essas entradas no arquivo sources.list para acessar os repositórios do QGIS 3:

deb https://qgis.org/debian bionic main
deb-src https://qgis.org/debian bionic main

d) Digite os comandos abaixo no Terminal para importação da chave pública:

wget -O - https://qgis.org/downloads/qgis-2017.gpg.key | gpg --import
gpg --fingerprint CAEB3DC3BDF7FB45
gpg --export --armor CAEB3DC3BDF7FB45 | sudo apt-key add -

e) Atualize sua lista de fontes

sudo apt-get update

f) Faça a instalação do QGIS + GRASS GIS + SAGA GIS

sudo apt-get install qgis python-qgis qgis-plugin-grass saga

Link para assistir o vídeo no YouTube

Nossa experiência com Geoprocessamento ao longo do tempo demonstrou que a publicação de vídeos é o caminho ideal para o aprendizado sobre inúmeras ferramentas. Caso você tenha interesse em adquirir esse conhecimento, acesse este link ou clique na imagem abaixo para assistir o vídeo no Youtube.

Compartilhe conosco a sua experiência com a ferramenta QGIS 3.0 no sistema Linux!

Informações

Instrutor GIS é o site de consultoria do Geógrafo Jorge Santos.

Jorge Santos é Instrutor de Geotecnologias, Produtor de Conteúdo Geo, Técnico em Geoprocessamento, Analista em Geoprocessamento e Designer Gráfico com mais de dez anos de experiência.

Contatos

  • WhatsApp: (61) 99616-5665
  • Skype: jorgepsantos2002
  • E-mail: jorgepsantos@instrutorgis.com.br

NewsLetter InstrutorGIS

Assine para ter Acesso:

À conteúdos em PDF de alta qualidade exclusivos para assinantes da newsletter.

Aos melhores tutoriais e artigos direto na sua caixa de e-mail.

Às promoções, eventos, sorteios e muito mais...

13 comentários em “QGIS 3: Roteiro para a Instalação do Linux Ubuntu 18.04 ‘Bionic Beaver’”

  1. Olá jorge, tudo bem ?
    infelizmente não consegui instalar, eu acho que tem alguma sujeira de instalação que ficou para traz, conforme o erro da instalação esta informando segue:

    Os pacotes a seguir têm dependências desencontradas:
    python-qgis : Depende: python-qgis-common (= 1:3.4.3+28bionic) mas não será instalado
    Depende: libqgispython3.4.3 mas não será instalado
    Depende: libqgis-3d3.4.3 mas não será instalado
    Depende: libqgis-analysis3.4.3 mas não será instalado
    Depende: libqgis-core3.4.3 mas não será instalado
    Depende: libqgis-gui3.4.3 mas não será instalado
    Depende: libqgis-server3.4.3 mas não será instalado
    Depende: libqscintilla2-qt5-13 (>= 2.8.4) mas não é instalável
    Depende: libqt5core5a (>= 5.9.0~beta) mas 5.5.1+dfsg-16ubuntu7.5 está para ser instalado
    Depende: libqt5svg5 (>= 5.6.0~beta) mas 5.5.1-2build1 está para ser instalado
    Depende: libqt5widgets5 (>= 5.7.0) mas 5.5.1+dfsg-16ubuntu7.5 está para ser instalado
    Depende: sip-api-12.3 mas não é instalável
    qgis : Depende: gdal-abi-2-2-3 mas não é instalável
    Depende: libgdal20 (>= 1.8.0) mas não é instalável
    Depende: libgsl23 mas não é instalável
    Depende: libgslcblas0 mas não é instalável
    Depende: libqgis-analysis3.4.3 mas não será instalado
    Depende: libqgis-app3.4.3 mas não será instalado
    Depende: libqgis-core3.4.3 mas não será instalado
    Depende: libqgis-gui3.4.3 mas não será instalado
    Depende: libqt5core5a (>= 5.9.0~beta) mas 5.5.1+dfsg-16ubuntu7.5 está para ser instalado
    Depende: libqt5gui5 (>= 5.8.0) mas 5.5.1+dfsg-16ubuntu7.5 está para ser instalado
    Depende: libqt5keychain1 (>= 0.7.0) mas não é instalável
    Depende: qgis-providers (= 1:3.4.3+28bionic) mas não será instalado
    Depende: qgis-common (= 1:3.4.3+28bionic) mas não será instalado
    qgis-plugin-grass : Depende: qgis-provider-grass (= 1:3.4.3+28bionic) mas não será instalado
    Depende: libgdal20 (>= 1.8.0) mas não é instalável
    Depende: libqgis-app3.4.3 mas não será instalado
    Depende: libqgis-core3.4.3 mas não será instalado
    Depende: libqgis-gui3.4.3 mas não será instalado
    Depende: libqgisgrass7-3.4.3 mas não será instalado
    Depende: libqt5core5a (>= 5.9.0~beta) mas 5.5.1+dfsg-16ubuntu7.5 está para ser instalado
    Depende: libqt5gui5 (>= 5.7.0) mas 5.5.1+dfsg-16ubuntu7.5 está para ser instalado
    Depende: libqt5svg5 (>= 5.6.0~beta) mas 5.5.1-2build1 está para ser instalado
    Depende: grass740 mas não é instalável
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados

  2. Jorge boa tarde. Excelente vídeo e tutorial, obrigado por compartilhar.
    Estou iniciando no Linux. Tentei instalar mas não houve sucesso.

    robson@robson-VirtualBox:~$ cat `ls /etc/*release /etc/*version`
    buster/sid
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=18.04
    DISTRIB_CODENAME=bionic
    DISTRIB_DESCRIPTION=”Ubuntu 18.04.2 LTS”
    NAME=”Ubuntu”
    VERSION=”18.04.2 LTS (Bionic Beaver)”
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME=”Ubuntu 18.04.2 LTS”
    VERSION_ID=”18.04″

    https://github.com/jorgepsantos2002/instrutorgis/issues/1

  3. Jorge desintalei o Qgis, mas não deu certo. Como estava usando máquina virtual, reinstalei o Ubuntu na máquina virtual e instalei o Qgis utilizando seu tutorial e ocorreu tudo certo. Obrigado.

  4. Ótimo o tutorial!!!
    Instalou corretamente e está funcionando aparentemente sem problemas.
    Muito obrigado!

    Farei contato …

    Cordial Abraço

  5. Ola boa tarde, fiz a desistalação completa conforme tutorial, e tentei instalar a versão nova mas ocorre este erro :
    Alguns pacotes não puderam ser instalados. Isto pode significar que
    você solicitou uma situação impossível ou, se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram retirados da “Incoming”.
    A informação a seguir pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências desencontradas:
    python-qgis : Depende: libqgis-analysis3.6.0 mas não será instalado
    qgis : Depende: gdal-abi-2-2-3
    Depende: libqgis-analysis3.6.1 mas não será instalado
    Depende: libqgis-app3.6.1 mas não será instalado
    Depende: python3-qgis (= 1:3.6.1+28bionic) mas não será instalado
    qgis-plugin-grass : Depende: grass740
    Depende: libqgis-app3.6.1 mas não será instalado
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

    algum procedimento de sugestão para conseguir instalar?

  6. Boa tarde, estou com este erro e nao consigo instalar , alguma sugestão?

    Alguns pacotes não puderam ser instalados. Isto pode significar que
    você solicitou uma situação impossível ou, se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram retirados da “Incoming”.
    A informação a seguir pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências desencontradas:
    python-qgis : Depende: libqgis-analysis3.6.0 mas não será instalado
    qgis : Depende: gdal-abi-2-2-3
    Depende: libqgis-analysis3.6.1 mas não será instalado
    Depende: libqgis-app3.6.1 mas não será instalado
    Depende: python3-qgis (= 1:3.6.1+28bionic) mas não será instalado
    qgis-plugin-grass : Depende: grass740
    Depende: libqgis-app3.6.1 mas não será instalado
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Deixe um comentário